I am building another GWT component and ran across two IE quirks that I would like to share.

1. Multiple modules on one page: I could not find a way to have two GWT modules on the same page–that is, having two gwt:module meta tags on one page. (Having two on one page works fine in FireFox, as long as gwt.js is only included once.) Instead, I followed the advice in this post, and created a hybrid module that inherited from both modules I wanted to display. In the two modules I was inheriting from, I simply check to see if a span is available to put the module’s UI in. (Don’t forget that inheritance is defined differently for GWT than for a typical programming language.)

2. Cookie size limits: Cookies set by GWT have limit in size in IE. Again, I didn’t see the same behavior with FF1.5, but IE 6.00.29 has a limit of 802 characters in the value portion of a cookie. (The name I was using was 5 characters long.) Longer values can be set, and are sent to the server, but I could not find a way to read cookies with a length longer than 802. I didn’t drop down into JSNI because I looked at the Cookies source code and couldn’t see what I’d do different.

Update Dec 5 2006: I was trying to nail this down to submit a bug report to Google, but saw some really weird behavior with IE’s cookies. It seemed to handle a cookie longer than 802, then it seemed to not handle such a cookie, and now it is handling a cookie with value length of 1202. See this page for an example. The first two cookies have a length of 802, the second two have a length of 1202. Weird!

Technorati Tags: , , , ,

2 thoughts on “GWT Internet Explorer quirks

  1. Nigel Leck says:

    Has anyone been able to get around the single module restriction ? I’ve run into the same issue and since GWT is so new I was wondering if there was a work around.

  2. moore says:

    Hi Nigel,

    According this post: http://groups.google.com/group/Google-Web-Toolkit/msg/836edd9984d72210
    GWanTed has a way of loading multiple modules on one page. It might be worth a look.

    There’s also this thread: http://groups.google.com/group/Google-Web-Toolkit/browse_thread/thread/1106bc10356e9880/569278e0ef7d302e which is worth reading and discusses some module load issues.

    I didn’t see anything in the issue tracker, so if this is a big deal to you, and the workaround I describe above doesn’t help, you may want to file an issue.

Comments are closed.


© Moore Consulting, 2003-2019